【JAVA】1002 A+B for Polynomials (25分) PAT甲级 PAT (Advanced Level) Practice

   日期:2020-04-29     浏览:89    评论:0    
核心提示:1002 A+B for Polynomials (25分)This time, you are sjava

1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N 1 N_1 N1 a N 1 a_N1 aN1 N 2 N_2 N2 a N 2 a_N2 aN2 N K N_K NK a N K a_NK aNK
每个输入文件包含一个测试用例。 每个案例占用2行,并且每行包含一个多项式的信息:
K N 1 N_1 N1 a N 1 a_N1 aN1 N 2 N_2 N2 a N 2 a_N2 aN2 N K N_K NK a N K a_NK aNK

where K is the number of nonzero terms in the polynomial, N i N_i Niand a N i a_Ni aNi(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤ N K N_K NK​<⋯< N 2 N_2 N2< N 1 N_1 N1≤1000.
其中K是多项式中非零项的数量, N i N_i Niand a N i a_Ni aNi(i=1,2,⋯,K) 分别是指数和系数。 假设1≤K≤10,0≤ N K N_K NK​<⋯< N 2 N_2 N2< N 1 N_1 N1≤1000.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
对于每个测试用例,应在一行中输出A和B的总和,格式与输入相同。 请注意,每行末尾不得有多余的空间。 请精确到小数点后一位。

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:
3 2 1.5 1 2.9 0 3.2

要点

  1. 最难理解的是题目

  2. 请注意,每行末尾不得有多余的空间。

  3. 请精确到小数点后一位。

    System.out.printf("%.1f", C[i]);
    

代码

import java.util.Arrays;
import java.util.Scanner;

public class PolynomialAddition1 {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        Double[] A = new Double[1001];
        for (int i = 0; i < 1001; i++) { //防止 C[i] = A[i] + B[i];发生空指针异常
            A[i] = 0.0;
        }
        Double[] B = new Double[1001];
        for (int i = 0; i < 1001; i++) {//防止 C[i] = A[i] + B[i];发生空指针异常
            B[i] = 0.0;
        }

        int K = sc.nextInt();
        int index;
        while (K != 0) {
            index = sc.nextInt(); //指数
            A[index] = sc.nextDouble(); //系数
            K--;
        }
// System.out.println(Arrays.toString(A));

        K = sc.nextInt();
        while (K != 0) {
            index = sc.nextInt(); //指数
            B[index] = sc.nextDouble(); //系数
            K--;
        }
        sc.close();
// System.out.println(Arrays.toString(B));

        double[] C = new double[1001];
        int count = 0;
        for (int i = 0; i < 1001; i++) {
            if (A[i] != 0 || B[i] != 0) {
                count++;
                C[i] = A[i] + B[i];
            }
        }
// System.out.println(Arrays.toString(C));
        System.out.print(count);
        for (int i = 1000; i >= 0; i--) {
            if (C[i] != 0) {
                System.out.print(" " + i + " ");
                System.out.printf("%.1f", C[i]);
            }
        }
    }
}
 
打赏
 本文转载自:网络 
所有权利归属于原作者,如文章来源标示错误或侵犯了您的权利请联系微信13520258486
更多>最近资讯中心
更多>最新资讯中心
0相关评论

推荐图文
推荐资讯中心
点击排行
最新信息
新手指南
采购商服务
供应商服务
交易安全
关注我们
手机网站:
新浪微博:
微信关注:

13520258486

周一至周五 9:00-18:00
(其他时间联系在线客服)

24小时在线客服