HDU-4850 Wow! Such String!(模拟) ——26行代码AC

   日期:2020-11-10     浏览:82    评论:0    
核心提示:立志用更少的代码做更高效的表达Recently, doge starts to get interested in a strange problem: whether there exists a string A following all the rules below:1.The length of the string A is N .2.The string A contains only lowercase English alphabet letters.3.Each sub

立志用更少的代码做更高效的表达

Recently, doge starts to get interested in a strange problem: whether there exists a string A following all the rules below:

1.The length of the string A is N .
2.The string A contains only lowercase English alphabet letters.
3.Each substring of A with length equal to or larger than 4 can appear in the string exactly once.

Doge cannot solve the problem, so he turns to his brother Yuege for help. However, Yuege is busy setting problems. Would you please help doge solve this problem?

Input

There are several test cases, please process till EOF.
For each test case, there will be one line containing one integer N (1 ≤ N ≤ 500000).
Sum of all N will not exceed 5000000.

Output

For each case, please output one line consisting a valid string if such a string exists, or “Impossible” (without quotes) otherwise. You can output any string if there are multiple valid ones.

Sample Input

5
3
11
10
6
17
8

Sample Output

pwned
wow
suchproblem
manystring
soeasy
muchlinearalgebra
abcdabch

题意

给你一个整数n,让你输出一个字符串。必须满足以下条件:

1.字符串的长度为n。

2.这个字符串只包含小写字母。

3.字符串中长度大于等于4的子串最多只能出现一次。

如果无解输出Impossible。

解题思路

因为大于等于4的子串只能出现一次,所以不会重复的串最长只会达到4^26+3 = 456979的长度。

因此, 我们可以预先打一个不会重复的字符表出来

若n>456979 ,则输出Impossible。

否则输出表的前n项。

打表的方式用循环即可。

代码解析

#include<iostream>
using namespace std;
int vis[26][26][26][26];
int s[5000005]; 
int main() { 
	ios::sync_with_stdio;
	
	for(int i = 0; i < 26; i++) 
		s[i*4] = s[i*4+1] = s[i*4+2] = s[i*4+3] = i;
	
	for(int i = 3; i < 26*4; i++) 
		vis[s[i-3]][s[i-2]][s[i-1]][s[i]]=1;
	
	for(int i=26*4; i < 456979; i++) 	//xx
		for(int j = 25; j >= 0; j--) 
			if(vis[s[i-3]][s[i-2]][s[i-1]][j]==0) { 
				vis[s[i-3]][s[i-2]][s[i-1]][j]=1;
				s[i] = j;
				break;
			}
	
	int n; while(cin>>n) { 
		if(n > 456979) {  cout << "Impossible" << '\n'; }
		else { 
			for(int i = 0; i < n; i++) putchar(s[i]+97);
			putchar('\n');
		}
	}
	return 0;
} 
 
打赏
 本文转载自:网络 
所有权利归属于原作者,如文章来源标示错误或侵犯了您的权利请联系微信13520258486
更多>最近资讯中心
更多>最新资讯中心
0相关评论

推荐图文
推荐资讯中心
点击排行
最新信息
新手指南
采购商服务
供应商服务
交易安全
关注我们
手机网站:
新浪微博:
微信关注:

13520258486

周一至周五 9:00-18:00
(其他时间联系在线客服)

24小时在线客服