【SSL1383】车II

   日期:2020-08-20     浏览:92    评论:0    
核心提示:Description有一个nm的棋盘(n、m≤80,nm≤80)要在棋盘上放k(k≤20)个棋子,使得任意两个棋子不相邻。求合法的方案总数。Inputn,m,kOutput方案总数Sample Input3 3 2Sample Output24思路:状压DP我们先枚举出所有的状态,用dfsdfsdfs来枚举,即:void VL_dfs(int ans, int pos, int flag){ if(pos>n) { s[++num]=ans; c[nu

Description

有一个nm的棋盘(n、m≤80,nm≤80)要在棋盘上放k(k≤20)个棋子,使得任意两个棋子不相邻。求合法的方案总数。

Input

n,m,k

Output

方案总数

Sample Input

3 3 2

Sample Output

24

思路:

状压DP
我们先枚举出所有的状态,用 d f s dfs dfs来枚举,即:

void VL_dfs(int ans, int pos, int flag)
{
	if(pos>n)
	{
		s[++num]=ans;
		c[num]=flag;
		return;
	}
	VL_dfs(ans, pos+1, flag);
	VL_dfs(ans+(1<<pos-1), pos+2, flag+1);
}

接下来我们就开始DP
我们用两个变量来枚举状态,分别为当前状态和转移状态,要想它们之间能够互相转移,就必须有一个为0,然后在枚举放的棋子个数

代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<cstring>
using namespace std;

int n, m, k, num;
int s[10010], c[10010], f[82][1<<9][21];

void VL_dfs(int ans, int pos, int flag)
{
	if(pos>n)
	{
		s[++num]=ans;
		c[num]=flag;
		return;
	}
	VL_dfs(ans, pos+1, flag);
	VL_dfs(ans+(1<<pos-1), pos+2, flag+1);
}
int main(){
	scanf("%d%d%d", &n, &m, &k);
	if(n>m)swap(n, m);
	VL_dfs(0 ,1, 0);
	for(int i=1; i<=num; i++)
		f[1][s[i]][c[i]]=1;
	for(int i=2; i<=m; i++)
		for(int j=1; j<=num; j++)
			for(int r=1; r<=num; r++)
				if(!(s[j]&s[r]))
				{
					for(int l=0; l<=k; l++)
						if(l>=c[j])
							f[i][s[j]][l]+=f[i-1][s[r]][l-c[j]];
				}
	long long ans=0;
	for(int i=1; i<=num; i++)
		ans+=f[m][s[i]][k];
	printf("%lld", ans);
	return 0;
}

 
打赏
 本文转载自:网络 
所有权利归属于原作者,如文章来源标示错误或侵犯了您的权利请联系微信13520258486
更多>最近资讯中心
更多>最新资讯中心
0相关评论

推荐图文
推荐资讯中心
点击排行
最新信息
新手指南
采购商服务
供应商服务
交易安全
关注我们
手机网站:
新浪微博:
微信关注:

13520258486

周一至周五 9:00-18:00
(其他时间联系在线客服)

24小时在线客服